Studio Performance Issues

Incident Report for Dailymotion

Resolved

All Studio functionality has been fully restored.

While the issues have been resolved, our engineering team continues to closely monitor all Studio systems to ensure stability and prevent any recurrence.
Posted Jul 25, 2025 - 12:40 CEST

Investigating

We are currently experiencing issues with Studio functionality affecting user access and performance.

Current Impact:
• Some Studio sections may load slowly or appear missing
• Partners may experience difficulties accessing some data
Posted Jul 25, 2025 - 11:38 CEST
This incident affected: Dailymotion Studio (Media, Analytics, Embed settings, Organization).