Dailymotion Studio Access Fails from APAC

Incident Report for Dailymotion

Resolved

Access to Dailymotion Studio is back to normal after a mitigation
Posted Nov 20, 2025 - 08:07 CET

Update

Engineering Team is attending to the matter and putting measures to mitigate the issue. Investigation is still on-going
Posted Nov 20, 2025 - 07:01 CET

Investigating

We are currently investigating the issue
Posted Nov 20, 2025 - 06:38 CET
This incident affected: Dailymotion Studio (Media, Analytics, Embed settings, Organization).