Account Registration - Email verification service disruption

Incident Report for Dailymotion

Resolved

The email verification issue has been resolved. The root cause was identified as rate limiting on our email delivery system, which has now been addressed. Email verification for new account registrations is functioning normally.
Users who experienced missing verification emails during the incident can request a new verification email through their account settings or the registration page.
We apologize for any inconvenience caused during the sign-up process. Normal operations have been fully restored
Posted Oct 17, 2025 - 13:17 CEST

Update

We are continuing to investigate this issue.
Posted Oct 17, 2025 - 12:09 CEST

Investigating

We are currently investigating reports of verification emails not being delivered during the account creation process. New users may experience delays or missing verification emails when attempting to register. Our team is actively working to resolve this issue
Posted Oct 17, 2025 - 12:09 CEST
This incident affected: Dailymotion (Dailymotion Website, Mobile Application).